summaryrefslogtreecommitdiffstats
path: root/ext/gio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gio/Makefile.am')
-rw-r--r--ext/gio/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/ext/gio/Makefile.am b/ext/gio/Makefile.am
new file mode 100644
index 00000000..15d57449
--- /dev/null
+++ b/ext/gio/Makefile.am
@@ -0,0 +1,13 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstgio.la
+
+# sources used to compile this plug-in
+libgstgio_la_SOURCES = gstgio.c gstgiosink.c gstgiosrc.c
+
+libgstgio_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GIO_CFLAGS)
+libgstgio_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GIO_LIBS)
+libgstgio_la_LDFLAGS = $(GST_GIO_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstgio.h gstgiosink.h gstgiosrc.h