summaryrefslogtreecommitdiffstats
path: root/ext/hermes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/hermes/Makefile.am')
-rw-r--r--ext/hermes/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ext/hermes/Makefile.am b/ext/hermes/Makefile.am
new file mode 100644
index 00000000..b7447e5e
--- /dev/null
+++ b/ext/hermes/Makefile.am
@@ -0,0 +1,17 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstcolorspace.la
+
+if HAVE_CPU_I386
+ARCHSRCS = yuv2rgb_mmx16.s
+else
+ARCHSRCS =
+endif
+
+libcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
+libcolorspace_la_CFLAGS = $(GST_CFLAGS)
+if HAVE_LIBHERMES
+libcolorspace_la_LIBADD = $(HERMES_LIBS)
+endif
+
+noinst_HEADERS = gstcolorspace.h yuv2rgb.h