summaryrefslogtreecommitdiffstats
path: root/ext/mplex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/mplex/Makefile.am')
-rw-r--r--ext/mplex/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/ext/mplex/Makefile.am b/ext/mplex/Makefile.am
index 5f9d847f..d99b5b7c 100644
--- a/ext/mplex/Makefile.am
+++ b/ext/mplex/Makefile.am
@@ -1,11 +1,17 @@
-
plugin_LTLIBRARIES = libgstmplex.la
-libgstmplex_la_SOURCES = gstmplex.cc
-libgstmplex_la_CXXFLAGS = $(GST_CFLAGS) -I$(top_srcdir)/gst-libs/ext/mplex/
-libgstmplex_la_LIBADD = $(LIBM_LIBS) $(top_builddir)/gst-libs/ext/mplex/libmplex.la
-libgstmplex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-noinst_HEADERS = gstmplex.h
+libgstmplex_la_SOURCES = \
+ gstmplex.cc \
+ gstmplexibitstream.cc \
+ gstmplexjob.cc \
+ gstmplexoutputstream.cc
+libgstmplex_la_CXXFLAGS = $(GST_CFLAGS) $(MPLEX_CFLAGS)
+libgstmplex_la_LIBADD = $(MPLEX_LIBS)
+libgstmplex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+noinst_HEADERS = \
+ gstmplex.hh \
+ gstmplexibitstream.hh \
+ gstmplexjob.hh \
+ gstmplexoutputstream.hh