summaryrefslogtreecommitdiffstats
path: root/ext/smoothwave/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/smoothwave/Makefile.am')
-rw-r--r--ext/smoothwave/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/smoothwave/Makefile.am b/ext/smoothwave/Makefile.am
index f000c7a4..e46a9572 100644
--- a/ext/smoothwave/Makefile.am
+++ b/ext/smoothwave/Makefile.am
@@ -8,4 +8,12 @@ libgstsmoothwave_la_LIBADD = $(GTK_LIBS)
noinst_HEADERS = gstsmoothwave.h
+if HAVE_GTK
+noinst_PROGRAMS = demo-osssrc
+endif
+
+demo_osssrc_SOURCES = demo-osssrc.c
+demo_osssrc_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_osssrc_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)
+
EXTRA_DIST = README