summaryrefslogtreecommitdiffstats
path: root/gst-libs/ext/ffmpeg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/ext/ffmpeg/Makefile.am')
-rw-r--r--gst-libs/ext/ffmpeg/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/gst-libs/ext/ffmpeg/Makefile.am b/gst-libs/ext/ffmpeg/Makefile.am
index 1dd50de9..b2ace5f0 100644
--- a/gst-libs/ext/ffmpeg/Makefile.am
+++ b/gst-libs/ext/ffmpeg/Makefile.am
@@ -3,7 +3,13 @@ EXTRA_DIST = Tag
# this doesn't trigger the distdir target in the ffmpeg checkout
DIST_SUBDIRS =
-SUBDIRS = ffmpeg
+if USE_FFMPEG
+FFMPEG_DIR=ffmpeg
+else
+FFMPEG_DIR=
+endif
+
+SUBDIRS = $(FFMPEG_DIR)
DISTFILES = \
ffmpeg/Changelog \
@@ -16,6 +22,7 @@ DISTFILES = \
ffmpeg/configure \
ffmpeg/Makefile \
ffmpeg/cygwin_inttypes.h \
+ ffmpeg/ffserver.h \
ffmpeg/ffmpeg.c \
ffmpeg/ffserver.c \
ffmpeg/berrno.h \