summaryrefslogtreecommitdiffstats
path: root/gst-libs/ext/mplex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/ext/mplex/Makefile.am')
-rw-r--r--gst-libs/ext/mplex/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gst-libs/ext/mplex/Makefile.am b/gst-libs/ext/mplex/Makefile.am
new file mode 100644
index 00000000..71d8aeb7
--- /dev/null
+++ b/gst-libs/ext/mplex/Makefile.am
@@ -0,0 +1,26 @@
+
+EXTRA_DIST = README INSTRUCT TODO
+
+noinst_LTLIBRARIES = libmplex.la
+
+libmplex_la_SOURCES = \
+ bits.cc bits.hh \
+ buffer.cc buffer.hh \
+ videostrm.hh audiostrm.hh padstrm.hh \
+ videostrm_in.cc padstrm.cc \
+ lpcmstrm_in.cc mpastrm_in.cc ac3strm_in.cc \
+ videostrm_out.cc audiostrm_out.cc \
+ multplex.cc outputstream.hh \
+ systems.cc systems.hh \
+ vector.cc vector.hh mplexconsts.hh \
+ inputstrm.cc inputstrm.hh aunit.hh \
+ stillsstream.cc stillsstream.hh \
+ mjpeg_logging.cc mjpeg_logging.h \
+ yuv4mpeg.cc yuv4mpeg_ratio.cc yuv4mpeg.h \
+ mpegconsts.cc mpegconsts.h
+
+libmplex_la_CXXFLAGS = $(GST_CFLAGS)
+libmplex_la_LIBADD = -lstdc++ $(LIBM_LIBS)
+libmplex_la_LDFLAGS =
+
+