summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/gconf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/gconf/Makefile.am')
-rw-r--r--gst-libs/gst/gconf/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/gst-libs/gst/gconf/Makefile.am b/gst-libs/gst/gconf/Makefile.am
new file mode 100644
index 00000000..d1d10e86
--- /dev/null
+++ b/gst-libs/gst/gconf/Makefile.am
@@ -0,0 +1,17 @@
+librarydir = $(prefix)/lib/gst
+
+library_LTLIBRARIES = libgstgconf.la
+
+libgstgconf_la_SOURCES = gconf.c
+
+libgstgconfincludedir = $(includedir)/@PACKAGE@-@VERSION@/gst/gconf
+libgstgconfinclude_HEADERS = gconf.h
+
+noinst_PROGRAMS = test-gconf
+
+test_gconf_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
+test_gconf_LDADD = $(GST_LIBS) $(GCONF_LIBS) -lgstgconf
+
+libgstgconf_la_LIBADD = $(GCONF_LIBS)
+libgstgconf_la_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
+libgstgconf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)