summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/idct/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/idct/Makefile.am')
-rw-r--r--gst-libs/gst/idct/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/gst-libs/gst/idct/Makefile.am b/gst-libs/gst/idct/Makefile.am
new file mode 100644
index 00000000..8dabafab
--- /dev/null
+++ b/gst-libs/gst/idct/Makefile.am
@@ -0,0 +1,31 @@
+if HAVE_LIBMMX
+GSTIDCTARCH_SRCS = mmxidct.S mmx32idct.c sseidct.S
+else
+GSTIDCTARCH_SRCS =
+endif
+
+librarydir = $(libdir)/gst
+
+library_LTLIBRARIES = libgstidct.la
+
+libgstidct_la_SOURCES = \
+ fastintidct.c \
+ floatidct.c \
+ gstidct.c \
+ intidct.c \
+ $(GSTIDCTARCH_SRCS)
+
+libgstidctincludedir = $(includedir)/gst/idct
+libgstidctinclude_HEADERS = idct.h
+
+check_PROGRAMS = ieeetest
+
+ieeetest_SOURCES = ieeetest.c
+ieeetest_LDADD = libgstidct.la
+ieeetest_CFLAGS = $(GST_CFLAGS)
+ieeetest_LDFLAGS = $(GST_LIBS)
+
+noinst_HEADERS = dct.h
+
+libgstidct_la_LIBADD = $(GST_LIBS)
+libgstidct_la_CFLAGS = $(GST_CFLAGS) -finline-functions -ffast-math