summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/mixer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/mixer/Makefile.am')
-rw-r--r--gst-libs/gst/mixer/Makefile.am36
1 files changed, 30 insertions, 6 deletions
diff --git a/gst-libs/gst/mixer/Makefile.am b/gst-libs/gst/mixer/Makefile.am
index ca153dd0..7871a24d 100644
--- a/gst-libs/gst/mixer/Makefile.am
+++ b/gst-libs/gst/mixer/Makefile.am
@@ -1,23 +1,30 @@
-libgstinterfacesincludedir = \
+libgstmixerincludedir = \
$(includedir)/gstreamer-@GST_MAJORMINOR@/gst/mixer
-libgstinterfacesinclude_HEADERS = \
+mixer_headers = \
mixer.h \
mixertrack.h
+built_headers = \
+ mixermarshal.h \
+ mixerenumtypes.h
+
+libgstmixerinclude_HEADERS = $(mixer_headers) $(built_headers)
+
noinst_LTLIBRARIES = libgstmixer.la
libgstmixer_la_SOURCES = \
mixer.c \
mixertrack.c \
- mixermarshal.c
+ mixermarshal.c \
+ mixerenumtypes.c
libgstmixer_la_CFLAGS = $(GST_CFLAGS)
BUILT_SOURCES = \
mixermarshal.c \
- mixermarshal.h
-built_headers = \
- mixermarshal.h
+ mixermarshal.h \
+ mixerenumtypes.c \
+ mixerenumtypes.h
EXTRA_DIST = mixermarshal.list
@@ -31,3 +38,20 @@ mixermarshal.c: mixermarshal.list
echo "#include \"mixermarshal.h\"" >> mixermarshal.c.tmp
glib-genmarshal --body --prefix=gst_mixer_marshal $^ >> mixermarshal.c.tmp
mv mixermarshal.c.tmp mixermarshal.c
+
+mixerenumtypes.h: $(mixer_headers)
+ glib-mkenums \
+ --fhead "#ifndef __GST_MIXER_ENUM_TYPES_H__\n#define __GST_MIXER_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+ --fprod "/* enumerations from \"@filename@\" */\n" \
+ --vhead "GType @enum_name@_get_type (void);\n#define GST_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \
+ --ftail "G_END_DECLS\n\n#endif /* __GST_MIXER_ENUM_TYPES_H__ */" \
+ $^ > $@
+
+mixerenumtypes.c: $(mixer_headers)
+ glib-mkenums \
+ --fhead "#include <mixer.h>" \
+ --fprod "\n/* enumerations from \"@filename@\" */" \
+ --vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
+ --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
+ --vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
+ $^ > $@