summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/mixer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/mixer/Makefile.am')
-rw-r--r--gst-libs/gst/mixer/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/gst-libs/gst/mixer/Makefile.am b/gst-libs/gst/mixer/Makefile.am
index 193b5a10..ca153dd0 100644
--- a/gst-libs/gst/mixer/Makefile.am
+++ b/gst-libs/gst/mixer/Makefile.am
@@ -9,5 +9,25 @@ noinst_LTLIBRARIES = libgstmixer.la
libgstmixer_la_SOURCES = \
mixer.c \
- mixertrack.c
+ mixertrack.c \
+ mixermarshal.c
libgstmixer_la_CFLAGS = $(GST_CFLAGS)
+
+BUILT_SOURCES = \
+ mixermarshal.c \
+ mixermarshal.h
+built_headers = \
+ mixermarshal.h
+
+EXTRA_DIST = mixermarshal.list
+
+CLEANFILES = $(BUILT_SOURCES)
+
+mixermarshal.h: mixermarshal.list
+ glib-genmarshal --header --prefix=gst_mixer_marshal $^ > mixermarshal.h.tmp
+ mv mixermarshal.h.tmp mixermarshal.h
+
+mixermarshal.c: mixermarshal.list
+ echo "#include \"mixermarshal.h\"" >> mixermarshal.c.tmp
+ glib-genmarshal --body --prefix=gst_mixer_marshal $^ >> mixermarshal.c.tmp
+ mv mixermarshal.c.tmp mixermarshal.c