summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/resample/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/resample/Makefile.am')
-rw-r--r--gst-libs/gst/resample/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gst-libs/gst/resample/Makefile.am b/gst-libs/gst/resample/Makefile.am
new file mode 100644
index 00000000..4fe42224
--- /dev/null
+++ b/gst-libs/gst/resample/Makefile.am
@@ -0,0 +1,26 @@
+libdir = $(libdir)/gst
+
+lib_LTLIBRARIES = libresample.la
+
+if HAVE_CPU_I386
+ARCHCFLAGS = -march=i486
+else
+if HAVE_CPU_PPC
+ARCHCFLAGS = -Wa,-m7400
+else
+ARCHCFLAGS =
+endif
+endif
+
+libresample_la_SOURCES = dtos.c functable.c resample.c resample.h
+libresample_la_LIBADD = $(GST_LIBS)
+libresample_la_CFLAGS = $(GST_CFLAGS) -ffast-math $(ARCHCFLAGS)
+
+noinst_HEADERS = resample.h
+
+#check_PROGRAMS = test
+#test_SOURCES = test.c
+#test_LDADD = libresample.la
+
+
+