summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/riff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/riff/Makefile.am')
-rw-r--r--gst-libs/gst/riff/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/gst-libs/gst/riff/Makefile.am b/gst-libs/gst/riff/Makefile.am
new file mode 100644
index 00000000..ba4a17ba
--- /dev/null
+++ b/gst-libs/gst/riff/Makefile.am
@@ -0,0 +1,11 @@
+libdir = $(prefix)/lib/gst
+
+lib_LTLIBRARIES = libgstriff.la
+
+libgstriff_la_SOURCES = riffparse.c riffencode.c riffutil.c
+
+libgstriffincludedir = $(includedir)/gst/riff
+libgstriffinclude_HEADERS = riff.h
+
+libgstriff_la_LIBADD = $(GST_LIBS)
+libgstriff_la_CFLAGS = $(GST_CFLAGS) -funroll-all-loops -finline-functions -ffast-math