summaryrefslogtreecommitdiffstats
path: root/gst/deinterlace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/deinterlace/Makefile.am')
-rw-r--r--gst/deinterlace/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/gst/deinterlace/Makefile.am b/gst/deinterlace/Makefile.am
index 22a691b5..3c1b5f5a 100644
--- a/gst/deinterlace/Makefile.am
+++ b/gst/deinterlace/Makefile.am
@@ -1,9 +1,10 @@
plugin_LTLIBRARIES = libgstdeinterlace.la
-# NOTE: we don't need $(GST_PLUGINS_BASE_LIBS) at the moment
libgstdeinterlace_la_SOURCES = gstdeinterlace.c
-libgstdeinterlace_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
-libgstdeinterlace_la_LIBADD = $(GST_BASE_LIBS)
+libgstdeinterlace_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
+libgstdeinterlace_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS)
libgstdeinterlace_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstdeinterlace.h