summaryrefslogtreecommitdiffstats
path: root/gst/librfb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/librfb/Makefile.am')
-rw-r--r--gst/librfb/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/gst/librfb/Makefile.am b/gst/librfb/Makefile.am
new file mode 100644
index 00000000..67505440
--- /dev/null
+++ b/gst/librfb/Makefile.am
@@ -0,0 +1,30 @@
+
+# please keep librfb easily extractable
+
+noinst_LTLIBRARIES = librfb.la
+plugin_LTLIBRARIES = libgstrfbsrc.la
+
+libgstrfbsrc_la_SOURCES = gstrfbsrc.c
+libgstrfbsrc_la_CFLAGS = $(GST_CFLAGS) -I/usr/local/include/librfb-0.1
+libgstrfbsrc_la_LIBADD = librfb.la
+libgstrfbsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+
+noinst_HEADERS = \
+ rfb.h \
+ rfbdecoder.h \
+ rfbbuffer.h \
+ rfbbytestream.h
+
+librfb_la_SOURCES = \
+ rfb.h \
+ rfbdecoder.c \
+ rfbdecoder.h \
+ rfbbuffer.c \
+ rfbbuffer.h \
+ rfbbytestream.c \
+ rfbbytestream.h
+
+librfb_la_CFLAGS = $(RFB_CFLAGS)
+librfb_la_LIBADD = $(GLIB_LIBS)
+