summaryrefslogtreecommitdiffstats
path: root/gst/nsf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/nsf/Makefile.am')
-rw-r--r--gst/nsf/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/gst/nsf/Makefile.am b/gst/nsf/Makefile.am
new file mode 100644
index 00000000..bff272a2
--- /dev/null
+++ b/gst/nsf/Makefile.am
@@ -0,0 +1,36 @@
+
+plugin_LTLIBRARIES = libgstnsf.la
+
+NOSEFART_SOURCES=fmopl.c \
+ log.c \
+ mmc5_snd.c \
+ nes_apu.c \
+ vrc7_snd.c \
+ fds_snd.c \
+ memguard.c \
+ nes6502.c \
+ nsf.c \
+ vrcvisnd.c
+
+NOSEFART_INCLUDES=fmopl.h \
+ log.h \
+ mmc5_snd.h \
+ nes_apu.h \
+ osd.h \
+ vrc7_snd.h \
+ fds_snd.h \
+ memguard.h \
+ nes6502.h \
+ nsf.h \
+ types.h \
+ vrcvisnd.h
+
+libgstnsf_la_SOURCES = gstnsf.c $(NOSEFART_SOURCES)
+
+libgstnsf_la_CFLAGS = $(GST_CFLAGS) -DNSF_PLAYER
+libgstnsf_la_LIBADD =
+libgstnsf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstnsf.h $(NOSEFART_INCLUDES)
+
+EXTRA_DIST =