summaryrefslogtreecommitdiffstats
path: root/gst/speed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/speed/Makefile.am')
-rw-r--r--gst/speed/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/gst/speed/Makefile.am b/gst/speed/Makefile.am
index 35aed207..c20b1d20 100644
--- a/gst/speed/Makefile.am
+++ b/gst/speed/Makefile.am
@@ -6,3 +6,11 @@ libgstspeed_la_SOURCES = gstspeed.c
libgstspeed_la_CFLAGS = $(GST_CFLAGS)
noinst_HEADERS = gstspeed.h filter.func
+
+if HAVE_GTK
+noinst_PROGRAMS = demo-mp3
+endif
+
+demo_mp3_SOURCES = demo-mp3.c
+demo_mp3_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_mp3_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)