summaryrefslogtreecommitdiffstats
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am38
1 files changed, 20 insertions, 18 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index cad9e26e..bd93f27c 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -7,36 +7,38 @@ GCONF_PC_UNINSTALLED=
endif
### all of the standard pc files we need to generate
-pcfiles = \
+pcverfiles = \
$(GCONF_PC) \
+ gstreamer-interfaces-@GST_MAJORMINOR@.pc \
gstreamer-libs-@GST_MAJORMINOR@.pc \
- gstreamer-play-@GST_MAJORMINOR@.pc \
- gstreamer-interfaces-@GST_MAJORMINOR@.pc
-pcfiles_uninstalled = \
+ gstreamer-media-info-@GST_MAJORMINOR@.pc \
+ gstreamer-play-@GST_MAJORMINOR@.pc
+pcverfiles_uninstalled = \
$(GCONF_PC_UNINSTALLED) \
+ gstreamer-interfaces-@GST_MAJORMINOR@-uninstalled.pc \
gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-interfaces-@GST_MAJORMINOR@-uninstalled.pc
+ gstreamer-media-info-@GST_MAJORMINOR@-uninstalled.pc \
+ gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc
-pcfiles_gconf = $(GCONF_PC) $(GCONF_PC_UNINSTALLED)
-all-local: $(pcfiles) $(pcfiles_uninstalled)
+pcverfiles_gconf = $(GCONF_PC) $(GCONF_PC_UNINSTALLED)
+all-local: $(pcverfiles) $(pcverfiles_uninstalled)
-### how to generate pc files from .pc files in this dir
-$(pcfiles): %-@GST_MAJORMINOR@.pc: %.pc
+### how to generate versioned .pc files from .pc files in this dir
+$(pcverfiles): %-@GST_MAJORMINOR@.pc: %.pc
cp $< $@
-$(pcfiles_uninstalled): %-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
+$(pcverfiles_uninstalled): %-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
cp $< $@
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = \
- $(GCONF_PC) \
- gstreamer-libs-@GST_MAJORMINOR@.pc \
- gstreamer-play-@GST_MAJORMINOR@.pc \
- gstreamer-interfaces-@GST_MAJORMINOR@.pc
+pkgconfig_DATA = $(pcverfiles)
-CLEANFILES = $(pcfiles) $(pcfiles_uninstalled)
-EXTRA_DIST= \
+CLEANFILES = $(pcverfiles) $(pcverfiles_uninstalled)
+pcinfiles = \
gstreamer-gconf.pc.in gstreamer-gconf-uninstalled.pc.in \
gstreamer-interfaces.pc.in gstreamer-interfaces-uninstalled.pc.in \
gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
+ gstreamer-media-info.pc.in gstreamer-media-info-uninstalled.pc.in \
gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in
+
+DISTCLEANFILES = $(pcinfiles:.in=)
+EXTRA_DIST = $(pcinfiles)