summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 2ced34ed..d2f77a5e 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -35,9 +35,11 @@ VCD_DIR=
endif
if USE_X
-X_DIR=ximage xvideo
+X_DIR=xvideo
+XI_DIR=ximage
else
X_DIR=
+X_DIR=
endif
if USE_XVIDEO
@@ -53,6 +55,6 @@ CDROM_DIR=
endif
SUBDIRS=$(DXR3_DIR) $(OSS_DIR) $(QCAM_DIR) $(V4L_DIR) $(V4L2_DIR) \
- $(VCD_DIR) $(CDROM_DIR) $(X_DIR) $(XV_DIR)
+ $(VCD_DIR) $(CDROM_DIR) $(X_DIR) $(XI_DIR) $(XV_DIR)
-DIST_SUBDIRS=dxr3 oss qcam v4l v4l2 vcd xvideo ximage glsink cdrom
+DIST_SUBDIRS=dxr3 oss qcam v4l v4l2 vcd xvideo ximage xvimage glsink cdrom