summaryrefslogtreecommitdiffstats
path: root/sys/dxr3/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/dxr3/Makefile.am')
-rw-r--r--sys/dxr3/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/sys/dxr3/Makefile.am b/sys/dxr3/Makefile.am
index 05e969a4..b0309afb 100644
--- a/sys/dxr3/Makefile.am
+++ b/sys/dxr3/Makefile.am
@@ -1,11 +1,25 @@
-plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+plugindir= $(libdir)/gstreamer-@GST_MAJORMINOR@
plugin_LTLIBRARIES = libgstdxr3.la
-libgstdxr3_la_SOURCES = gstdxr3videosink.c gstdxr3.c
+libgstdxr3_la_SOURCES = dxr3videosink.c dxr3audiosink.c dxr3spusink.c \
+ dxr3init.c ac3_padder.c dxr3marshal.c
libgstdxr3_la_CFLAGS = $(GST_CFLAGS)
libgstdxr3_la_LIBADD =
libgstdxr3_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstdxr3videosink.h
+BUILT_SOURCES = dxr3marshal.c dxr3marshal.h
+built_headers = dxr3marshal.h
+
+noinst_HEADERS = dxr3videosink.h dxr3audiosink.h dxr3spusink.h \
+ dxr3common.h ac3_padder.h
+
+dxr3marshal.h: dxr3marshal.list
+ glib-genmarshal --header --prefix=dxr3_marshal $^ > dxr3marshal.h.tmp
+ mv dxr3marshal.h.tmp dxr3marshal.h
+
+dxr3marshal.c: dxr3marshal.list
+ echo "#include \"dxr3marshal.h\"" >> dxr3marshal.c.tmp
+ glib-genmarshal --body --prefix=dxr3_marshal $^ >> dxr3marshal.c.tmp
+ mv dxr3marshal.c.tmp dxr3marshal.c