summaryrefslogtreecommitdiffstats
path: root/sys/glsink/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/glsink/Makefile.am')
-rw-r--r--sys/glsink/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys/glsink/Makefile.am b/sys/glsink/Makefile.am
index b4f72c92..6cb9dd10 100644
--- a/sys/glsink/Makefile.am
+++ b/sys/glsink/Makefile.am
@@ -1,6 +1,11 @@
plugin_LTLIBRARIES = libgstglimagesink.la
+noinst_PROGRAMS = color_matrix
+
+AM_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+AM_LIBS = $(GST_BASE_LIBS)
+
libgstglimagesink_la_SOURCES = \
glimagesink.c \
gstgldisplay.c \
@@ -11,7 +16,9 @@ libgstglimagesink_la_SOURCES = \
gstgldownload.c \
gstgltestsrc.c \
gltestsrc.c \
- gstglfilter.c
+ gstglfilter.c \
+ gstglfilterexample.c \
+ gstglconvert.c
libgstglimagesink_la_CFLAGS = $(GST_CFLAGS) $(X_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS)
libgstglimagesink_la_LIBADD = $(X_LIBS) $(XSHM_LIBS) -lGL \
@@ -25,4 +32,5 @@ noinst_HEADERS = \
glextensions.h \
gstgltestsrc.h \
gltestsrc.h \
- gstglbuffer.h
+ gstglbuffer.h \
+ gstglfilter.h