summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
new file mode 100644
index 00000000..d3637504
--- /dev/null
+++ b/tests/check/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/common/check.mak
+
+CHECK_REGISTRY = $(top_builddir)/tests/check/test-registry.xml
+
+GST_TOOLS_DIR = $(top_builddir)/tools
+
+REGISTRY_ENVIRONMENT = \
+ GST_REGISTRY=$(CHECK_REGISTRY)
+
+# FIXME: the PLUGIN_PATH has a hack to reach good for now
+# decide if it's worth it to add a .pc file for this, plus a dependancy on it
+TESTS_ENVIRONMENT = \
+ $(REGISTRY_ENVIRONMENT) \
+ GST_PLUGIN_SYSTEM_PATH= \
+ GST_PLUGIN_PATH=$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR)/../gst-plugins-good:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
+
+plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+
+# override to _not_ install the test plugins
+install-pluginLTLIBRARIES:
+
+# the core dumps of some machines have PIDs appended
+CLEANFILES = core.* test-registry.xml
+
+SUPPRESSIONS = $(top_srcdir)/common/gst.supp
+
+clean-local: clean-local-check
+
+check_PROGRAMS = \
+ elements/tagid3v2mux
+TESTS = $(check_PROGRAMS)
+
+AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
+LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)