summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index c1663887..96df1978 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -12,7 +12,7 @@ REGISTRY_ENVIRONMENT = \
TESTS_ENVIRONMENT = \
$(REGISTRY_ENVIRONMENT) \
GST_PLUGIN_SYSTEM_PATH= \
- GST_PLUGIN_PATH=$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR)/../gst-plugins-good:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
+ GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
@@ -26,9 +26,13 @@ SUPPRESSIONS = $(top_srcdir)/common/gst.supp
clean-local: clean-local-check
-check_PROGRAMS =
+check_PROGRAMS = \
+ elements/gdppay \
+ elements/gdpdepay
TESTS = $(check_PROGRAMS)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+
+elements_gdpdepay_LDFLAGS = $(LDADD) $(GST_GDP_LIBS)