summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index e69de29b..2c9080d1 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -0,0 +1,15 @@
+if USE_GST_V4L2
+
+GST_V4L2_TESTS = v4l2src-test
+
+v4l2src_test_SOURCES = v4l2src-test.c
+v4l2src_test_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS)
+
+v4l2src_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lgstinterfaces-$(GST_MAJORMINOR)
+
+else
+GST_V4L2_TESTS =
+endif
+
+noinst_PROGRAMS = $(GST_V4L2_TESTS)
+