summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index e3018d30..e1920fd2 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -12,5 +12,18 @@ else
GST_V4L2_TESTS =
endif
-noinst_PROGRAMS = $(GST_V4L2_TESTS)
+if USE_SOUNDTOUCH
+
+GST_SOUNDTOUCH_TESTS = pitch-test
+
+pitch_test_SOURCES = pitch-test.c
+pitch_test_CFLAGS = $(GST_CONTROLLER_CFLAGS)
+pitch_test_LDADD = $(GST_CONTROLLER_LIBS)
+pitch_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+else
+GST_SOUNDTOUCH_TESTS =
+endif
+
+noinst_PROGRAMS = $(GST_V4L2_TESTS) $(GST_SOUNDTOUCH_TESTS)