summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-04-08 17:19:10 +0000
committerDavid Robillard <d@drobilla.net>2007-04-08 17:19:10 +0000
commit679d5f9f3aca988bdebcd140b77e12d330380abc (patch)
tree94f5a4844f9aa23197dbb3df907850d26af77f4c /configure.ac
parentcd0a2541cb9b14bedf200a68ee774b506980775c (diff)
downloadingen-679d5f9f3aca988bdebcd140b77e12d330380abc.tar.gz
ingen-679d5f9f3aca988bdebcd140b77e12d330380abc.tar.bz2
ingen-679d5f9f3aca988bdebcd140b77e12d330380abc.zip
Jack MIDI API compatibility kluges.
git-svn-id: http://svn.drobilla.net/lad/ingen@418 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index caa84b2b..521a11c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,10 @@ if test "$build_server" = "yes" -o "$monolothic_ingenuity"; then
fi
if test "$build_jack_midi" = "yes"; then
AC_DEFINE(HAVE_JACK_MIDI, 1, [Has Jack MIDI])
+ AC_JACK_MIDI_NFRAMES_CHECK()
+ if test "$jackmidi_nframes" == "yes"; then
+ AC_DEFINE([JACK_MIDI_NEEDS_NFRAMES], 1, [Defined if we JACK MIDI functions need nframes parameter.])
+ fi
fi
# Check for ALSA