summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-10-04 21:45:20 +0000
committerDavid Robillard <d@drobilla.net>2006-10-04 21:45:20 +0000
commit30cb85c307b4c1273791721a782337742ade222c (patch)
tree020932d6f50ebbcd813c58f6f23e85a293587665 /configure.ac
parent32261ba465be203f973a0e126672b8d7188ba327 (diff)
downloadingen-30cb85c307b4c1273791721a782337742ade222c.tar.gz
ingen-30cb85c307b4c1273791721a782337742ade222c.tar.bz2
ingen-30cb85c307b4c1273791721a782337742ade222c.zip
Moved generic utility stuff to new library "raul".
git-svn-id: http://svn.drobilla.net/lad/ingen@156 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 23 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index f8722021..83c2b189 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,5 @@
AC_PREREQ(2.59)
AC_INIT([ingen],[0.4.0pre],[drobilla@connect.carleton.ca])
-AC_CONFIG_SRCDIR([src/common/util/CountedPtr.h])
AC_CONFIG_SRCDIR([src/common/interface/EngineInterface.h])
AC_CONFIG_SRCDIR([src/libs/engine/JackAudioDriver.cpp])
AC_CONFIG_SRCDIR([src/libs/engine/tests/node_tree_test.cpp])
@@ -42,9 +41,7 @@ AC_CHECK_LIB(pthread, pthread_create, [],
AC_MSG_ERROR([*** Ingen requires POSIX threads support]))
AC_CHECK_HEADER([pthread.h])
-# Check for POSIX semaphores in rt library
-AC_CHECK_HEADER([semaphore.h])
-AC_CHECK_LIB([rt], [sem_post])
+PKG_CHECK_MODULES(RAUL, raul >= 0.0.0)
# Check for LASH
build_lash="no"
@@ -389,7 +386,6 @@ AM_CONDITIONAL(BUILD_CLIENT_LIB, [test "$build_console_clients" = "yes" -o "$bui
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([src/Makefile])
AC_CONFIG_FILES([src/common/Makefile])
-AC_CONFIG_FILES([src/common/util/Makefile])
AC_CONFIG_FILES([src/common/interface/Makefile])
AC_CONFIG_FILES([src/libs/Makefile])
AC_CONFIG_FILES([src/libs/engine/Makefile])
@@ -409,25 +405,25 @@ AC_CONFIG_FILES([doc/Doxyfile])
AC_OUTPUT
# Display summary
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Ingen build configuration:])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Building server: $build_engine])
-AC_MSG_NOTICE([ Jack MIDI support: $build_jack_midi])
-AC_MSG_NOTICE([ ALSA MIDI support: $build_alsa_midi])
-AC_MSG_NOTICE([ LV2 Plugin support: $build_lv2])
-AC_MSG_NOTICE([ DSSI Plugin support: $build_dssi])
-AC_MSG_NOTICE([ LADSPA Plugin support: $build_ladspa])
-AC_MSG_NOTICE([ LASH support: $build_lash])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Building in-process engine: $build_in_process_engine])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Building console clients: $build_console_clients])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Building Ingenuity (GTK): $build_gtk_client])
-AC_MSG_NOTICE([ Monolithic: $monolithic_ingenuity])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Building with flags: $CXXFLAGS])
-AC_MSG_NOTICE([])
-AC_MSG_NOTICE([Please note the above and see README for performance information.])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Ingen build configuration:])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Building server: $build_engine])
+AC_MSG_RESULT([ Jack MIDI support: $build_jack_midi])
+AC_MSG_RESULT([ ALSA MIDI support: $build_alsa_midi])
+AC_MSG_RESULT([ LV2 Plugin support: $build_lv2])
+AC_MSG_RESULT([ DSSI Plugin support: $build_dssi])
+AC_MSG_RESULT([ LADSPA Plugin support: $build_ladspa])
+AC_MSG_RESULT([ LASH support: $build_lash])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Building in-process engine: $build_in_process_engine])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Building console clients: $build_console_clients])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Building Ingenuity (GTK): $build_gtk_client])
+AC_MSG_RESULT([ Monolithic: $monolithic_ingenuity])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Building with flags: $CXXFLAGS])
+AC_MSG_RESULT([])
+AC_MSG_RESULT([Please note the above and see README for performance information.])