summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-09-09 14:24:56 +0000
committerDavid Robillard <d@drobilla.net>2006-09-09 14:24:56 +0000
commitfca95e5d454d37bd74b98f5bce35cfcbaee86c3f (patch)
tree97fcf6e8afaf4356d46a24236e9aa2451ab55698 /configure.ac
parentb853b3dde1f7028dd275f78433a6ad9b5b9f61c7 (diff)
downloadingen-fca95e5d454d37bd74b98f5bce35cfcbaee86c3f.tar.gz
ingen-fca95e5d454d37bd74b98f5bce35cfcbaee86c3f.tar.bz2
ingen-fca95e5d454d37bd74b98f5bce35cfcbaee86c3f.zip
Drove 'er home! Working monolothic Ingenuity (ie. in-process engine).
Countless bugfixes. git-svn-id: http://svn.drobilla.net/lad/ingen@123 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac116
1 files changed, 65 insertions, 51 deletions
diff --git a/configure.ac b/configure.ac
index 901e42e4..a819f3fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,8 @@ if test "$build_lash" = "yes"; then
else
AC_MSG_WARN([LASH not found, session support will not be built.])
fi
+AC_MSG_WARN([NOTE: LASH support is not available at this time])
+
AM_CONDITIONAL(WITH_LASH, [test "$build_lash" = "yes"])
# Use debugging flag?
@@ -94,46 +96,40 @@ CFLAGS="$CFLAGS -pipe -fmessage-length=999"
##########################################################################
-## ENGINE
+## ENGINE (Universal engine options)
##########################################################################
-# Check for building engine
-build_engine="yes"
-AC_ARG_ENABLE([engine],
- AS_HELP_STRING(--enable-engine, Build engine (yes)),
- [ if test x$enable_engine = xno ; then build_engine=no ; fi ])
-
-# Check for building engine as an in-process jack client
+# Build support for running as an in-process jack client
build_in_process_engine="no"
AC_ARG_ENABLE([in-process-engine],
AS_HELP_STRING(--enable-in-process-engine, Build engine as an in-process Jack client (no)),
[ if test x$enable_in_process_engine = xyes ; then build_in_process_engine=yes ; fi ])
-# Jack MIDI option
+# Jack MIDI support
build_jack_midi="no"
AC_ARG_ENABLE(jack-midi,
[AS_HELP_STRING(--enable-jack-midi, [Enable Jack MIDI support (no)])],
[ if test x$enable_jack_midi = xyes ; then build_jack_midi=yes ; fi ])
-# ALSA option
+# ALSA support
build_alsa_midi="yes"
AC_ARG_ENABLE(alsa-midi,
[AS_HELP_STRING(--enable-alsa-midi, [Enable Alsa MIDI driver (yes)])],
[ if test x$enable_alsa_midi = xno ; then build_alsa_midi=no ; fi ])
-# LV2 option
+# LV2 support
build_lv2="yes"
AC_ARG_ENABLE(lv2,
- [AS_HELP_STRING(--enable-lv2, [Enable LV2 plugin support through libslv2 (yes)])],
+ [AS_HELP_STRING(--enable-lv2, [Enable LV2 plugin support through libslv2 (yes) - Requires: libslv2])],
[ if test x$enable_lv2 = xno ; then build_lv2=no ; fi ])
-# DSSI option
+# DSSI support
build_dssi="yes"
AC_ARG_ENABLE(dssi,
- [AS_HELP_STRING(--enable-dssi, [Enable DSSI plugin support (yes, requires Alsa)])],
+ [AS_HELP_STRING(--enable-dssi, [Enable DSSI plugin support (yes) - Requires: alsa])],
[ if test x$enable_dssi = xno ; then build_dssi=no ; fi ])
-# LADSPA option
+# LADSPA support
build_ladspa="yes"
AC_ARG_ENABLE(ladspa,
[AS_HELP_STRING(--enable-ladspa, [Enable LADSPA plugin support (yes)])],
@@ -141,11 +137,52 @@ AC_ARG_ENABLE(ladspa,
if test "$build_in_process_engine" = "yes"; then
- AC_DEFINE(BUILD_IN_PROCESS_ENGINE, 1, [Whether to build engine as Jack in-process client])
+ AC_DEFINE(BUILD_IN_PROCESS_ENGINE, 1, [Whether to support running as a Jack in-process client])
fi
-if test "$build_engine" = "yes" -o "$build_in_process_engine" = "yes"; then
+
+##########################################################################
+## COMPONENTS (options for which components to build)
+##########################################################################
+
+# Build unit tests?
+build_unit_tests="no"
+AC_ARG_ENABLE(unit-tests,
+ [AS_HELP_STRING(--enable-unit-tests, [Build unit tests (no) - Developers only])],
+ [build_unit_tests="$enableval"])
+
+# Stand-alone engine (OSC controlled)
+build_server="yes"
+AC_ARG_ENABLE([server],
+ AS_HELP_STRING(--enable-server, Build OSC controlled stand-alone engine (yes)),
+ [ if test x$enable_server = xno ; then build_server=no ; fi ])
+
+# Command-line clients
+build_console_clients="yes"
+AC_ARG_ENABLE([console-clients],
+ AS_HELP_STRING(--enable-console-clients, [Build command-line clients (yes) - Requires: libxml2, libsigc++]),
+ [ if test x$enable_console_clients = xno ; then build_console_clients=no ; fi ])
+
+# Gtk client (Ingenuity)
+build_gtk_client="yes"
+AC_ARG_ENABLE([gtk-client],
+ AS_HELP_STRING(--enable-gtk-client, [Build GTK client, Ingenuity (true)]),
+ [ if test x$enable_gtk_client = xno ; then build_gtk_client=no ; fi ])
+
+# Ingenuity with internal engine
+monolithic_ingenuity="$build_gtk_client"
+AC_ARG_ENABLE([monolithic-gtk-client],
+ AS_HELP_STRING(--enable-monolithic-gtk-client [Build Ingenuity with internal engine (true, if building Ingenuity)]),
+ [ if test x$enable_monolithic_gtk_client = xno ; then monolithic_gtk_client=no ; fi ])
+
+
+
+##########################################################################
+## SERVER
+##########################################################################
+
+if test "$build_server" = "yes" -o "$monolothic_ingenuity"; then
# Check for standard lib stuff
AC_CHECK_FUNCS([posix_memalign, fesetround])
AC_CHECK_HEADERS([float.h stddef.h fenv.h])
@@ -223,16 +260,10 @@ if test "$build_engine" = "yes" -o "$build_in_process_engine" = "yes"; then
fi
fi
- # Build unit tests?
- build_unit_tests="no"
- AC_ARG_ENABLE(unit-tests,
- [AS_HELP_STRING(--enable-unit-tests, [Build unit tests (no)])],
- [build_unit_tests="$enableval"])
-
else
- AC_MSG_WARN([Engine will NOT be built! (Nothing you're building produces sound)])
+ AC_MSG_WARN([Engine will NOT be built! (Nothing you're building produces any sound itself)])
fi
-AM_CONDITIONAL(BUILD_ENGINE, [test "$build_engine" = "yes"])
+AM_CONDITIONAL(BUILD_SERVER, [test "$build_server" = "yes"])
AM_CONDITIONAL(BUILD_IN_PROCESS_ENGINE, [test "$build_in_process_engine" = "yes"])
AM_CONDITIONAL(BUILD_UNIT_TESTS, [test "$build_unit_tests" = "yes"])
AM_CONDITIONAL(WITH_JACK_MIDI, [test "$build_jack_midi" = "yes"])
@@ -247,13 +278,8 @@ AM_CONDITIONAL(WITH_DSSI, [test "$build_dssi" = "yes"])
## Console Clients
##########################################################################
-build_console_clients="yes"
-AC_ARG_ENABLE([console-clients],
- AS_HELP_STRING(--enable-console-clients, Build console clients (true, requires libxml2)),
- [ if test x$enable_console_clients = xno ; then build_console_clients=no ; fi ])
-
if test "$build_console_clients" = "yes"; then
-
+
# Check for libxml2
PKG_CHECK_MODULES(LXML2, libxml-2.0 >= 2.6.0)
AC_SUBST(LXML2_LIBS)
@@ -271,58 +297,45 @@ AM_CONDITIONAL(BUILD_CONSOLE_CLIENTS, [test "$build_console_clients" = "yes"])
##########################################################################
-## GTK Client
+## GTK Client (Ingenuity)
##########################################################################
-# Check for building gtk client
-build_gtk_client="yes"
-AC_ARG_ENABLE([gtk-client],
- AS_HELP_STRING(--enable-gtk-client, Build GTK client. (true, requires console clients)),
- [ if test x$enable_gtk_client = xno ; then build_gtk_client=no ; fi ])
-
-if test "$build_console_clients" = "no"; then
- AC_MSG_WARN([GTK client will NOT be built! (requires console clients)])
- build_gtk_client=no
-fi
if test "$build_gtk_client" = "yes"; then
- # Checks for header files.
+ # Check misc. system stuff
AC_CHECK_HEADERS([string.h sys/time.h unistd.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_TIME
-
- # Checks for library functions.
AC_FUNC_ERROR_AT_LINE
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_STAT
AC_CHECK_FUNCS([gettimeofday mkdir strcasecmp strchr strdup strtol])
- # Check for GTKMM
PKG_CHECK_MODULES(GTKMM, gtkmm-2.4)
AC_SUBST(GTKMM_CFLAGS)
AC_SUBST(GTKMM_LIBS)
- # Check for gnomecanvasmm
PKG_CHECK_MODULES(GNOMECANVASMM, libgnomecanvasmm-2.6)
AC_SUBST(GNOMECANVASMM_CFLAGS)
AC_SUBST(GNOMECANVASMM_LIBS)
- # Check for libglademm
PKG_CHECK_MODULES(LIBGLADEMM, libglademm-2.4)
AC_SUBST(LIBGLADEMM_CFLAGS)
AC_SUBST(LIBGLADEMM_LIBS)
- # Check for FlowCanvas
PKG_CHECK_MODULES(FLOWCANVAS, flowcanvas >= 0.1.0)
AC_SUBST(FLOWCANVAS_CFLAGS)
AC_SUBST(FLOWCANVAS_LIBS)
+
+ if test "$monolithic_ingenuity" = "yes"; then
+ AC_DEFINE(MONOLITHIC_INGENUITY, 1, [Whether to build an internal engine into Ingenuity])
+ fi
else
AC_MSG_WARN([GTK client will NOT be built!])
fi
AM_CONDITIONAL(BUILD_GTK_CLIENT, [test "$build_gtk_client" = "yes"])
+AM_CONDITIONAL(MONOLITHIC_INGENUITY, [test "$monolithic_ingenuity" = "yes"])
# Build client lib if anything above that depends on it is to be built
AM_CONDITIONAL(BUILD_CLIENT_LIB, [test "$build_console_clients" = "yes" -o "$build_gtk_client" = "yes"])
@@ -367,6 +380,7 @@ AC_MSG_NOTICE([])
AC_MSG_NOTICE([Building console clients: $build_console_clients])
AC_MSG_NOTICE([])
AC_MSG_NOTICE([Building Ingenuity (GTK): $build_gtk_client])
+AC_MSG_NOTICE([ Monolithic: $monolithic_ingenuity])
AC_MSG_NOTICE([])
AC_MSG_NOTICE([])
AC_MSG_NOTICE([Building with flags: $CXXFLAGS])