summaryrefslogtreecommitdiffstats
path: root/src/bindings/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-08-01 04:42:09 +0000
committerDavid Robillard <d@drobilla.net>2007-08-01 04:42:09 +0000
commit1a77934531b0ddfc4392ccffbdde0058c2dbab68 (patch)
tree51e628c9b3dc4299d1f5dbb3bd5aad4938b0ae5a /src/bindings/Makefile.am
parent9cd4eddfb41c4573d4acd4f625572c4cdff50497 (diff)
downloadingen-1a77934531b0ddfc4392ccffbdde0058c2dbab68.tar.gz
ingen-1a77934531b0ddfc4392ccffbdde0058c2dbab68.tar.bz2
ingen-1a77934531b0ddfc4392ccffbdde0058c2dbab68.zip
Remove PostProcessor thread, post-process in main thread instead (solves scripting threading issues, and saves memory anyway).
Revert saw_lp.ingen.ttl (version written by broken raptor committed by mistake). Working engine->script responses, nicer Python example. git-svn-id: http://svn.drobilla.net/lad/ingen@665 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/bindings/Makefile.am')
-rw-r--r--src/bindings/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/bindings/Makefile.am b/src/bindings/Makefile.am
index 48a5ad4f..cb86a915 100644
--- a/src/bindings/Makefile.am
+++ b/src/bindings/Makefile.am
@@ -10,6 +10,11 @@ bindings_LTLIBRARIES = libingen_bindings.la
libingen_bindings_la_LDFLAGS = -no-undefined -module -avoid-version
libingen_bindings_la_LIBADD = @RAUL_LIBS@ @GLIBMM_LIBS@ #../libs/module/libingen_module.la
libingen_bindings_la_SOURCES = ingen_wrap.cxx ingen_bindings.cpp ingen_bindings.hpp
+libingen_bindings_la_CXXFLAGS = \
+ @SLV2_CFLAGS@ @RAUL_CFLAGS@ @GLIBMM_CFLAGS@ \
+ -I$(top_srcdir)/ingen/src/common \
+ -I$(top_srcdir)/ingen/src/libs \
+ -I/usr/include/python2.4
swig: ingen.i
swig -c++ -Wall $(FLAGS) -python ingen.i