summaryrefslogtreecommitdiffstats
path: root/src/libs/engine/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-04-08 06:04:32 +0000
committerDavid Robillard <d@drobilla.net>2007-04-08 06:04:32 +0000
commite96c36c1a7abb062e36efc0ac95c35fedcef922e (patch)
tree826d5caa0392201472d12c02a1c3df4cf7b275be /src/libs/engine/Makefile.am
parent7d69e89f22304e37fa325ce4f39a374a02072a69 (diff)
downloadingen-e96c36c1a7abb062e36efc0ac95c35fedcef922e.tar.gz
ingen-e96c36c1a7abb062e36efc0ac95c35fedcef922e.tar.bz2
ingen-e96c36c1a7abb062e36efc0ac95c35fedcef922e.zip
De-template-ification of port types (req. for LV2 MIDI, but nice code size reduction).
LV2 MIDI patching support (LV2 style MIDI throughout, inc. internal plugins). git-svn-id: http://svn.drobilla.net/lad/ingen@415 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/libs/engine/Makefile.am')
-rw-r--r--src/libs/engine/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/libs/engine/Makefile.am b/src/libs/engine/Makefile.am
index 03c42c52..29b601a9 100644
--- a/src/libs/engine/Makefile.am
+++ b/src/libs/engine/Makefile.am
@@ -38,11 +38,13 @@ libingen_la_SOURCES = \
OSCClientSender.h \
OSCClientSender.cpp \
Buffer.h \
- Buffer.cpp \
+ AudioBuffer.h \
+ AudioBuffer.cpp \
+ MidiBuffer.h \
+ MidiBuffer.cpp \
+ BufferFactory.cpp \
Port.h \
Port.cpp \
- TypedPort.h \
- TypedPort.cpp \
InputPort.h \
InputPort.cpp \
OutputPort.h \
@@ -73,8 +75,6 @@ libingen_la_SOURCES = \
PostProcessor.cpp \
Connection.h \
Connection.cpp \
- TypedConnection.h \
- TypedConnection.cpp \
ObjectStore.h \
ObjectStore.cpp \
TransportNode.h \