summaryrefslogtreecommitdiffstats
path: root/src/serialisation/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-09-30 16:50:21 +0000
committerDavid Robillard <d@drobilla.net>2008-09-30 16:50:21 +0000
commit93850c202de8b073a1ce1dd8bd246d407bce4e2f (patch)
tree6910b135bf4eff12de1af116cef73f6e9c107cd0 /src/serialisation/Makefile.am
parenta8bf5272d096de73507d2eab47f282c345f4ca8a (diff)
downloadingen-93850c202de8b073a1ce1dd8bd246d407bce4e2f.tar.gz
ingen-93850c202de8b073a1ce1dd8bd246d407bce4e2f.tar.bz2
ingen-93850c202de8b073a1ce1dd8bd246d407bce4e2f.zip
Flatten ingen source directory heirarchy a bit.
git-svn-id: http://svn.drobilla.net/lad/trunk/ingen@1551 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'src/serialisation/Makefile.am')
-rw-r--r--src/serialisation/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/serialisation/Makefile.am b/src/serialisation/Makefile.am
new file mode 100644
index 00000000..57e99055
--- /dev/null
+++ b/src/serialisation/Makefile.am
@@ -0,0 +1,24 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+moduledir = $(libdir)/ingen
+
+module_LTLIBRARIES = libingen_serialisation.la
+
+libingen_serialisation_la_CXXFLAGS = \
+ @INGEN_CFLAGS@ \
+ @REDLANDMM_CFLAGS@ \
+ @RAUL_CFLAGS@ \
+ @GLIBMM_CFLAGS@ \
+ @SLV2_CFLAGS@
+
+libingen_serialisation_la_LDFLAGS = -no-undefined -module -avoid-version
+libingen_serialisation_la_LIBADD = @RAUL_LIBS@ @REDLANDMM_LIBS@ @GLIBMM_LIBS@ @SLV2_LIBS@
+
+libingen_serialisation_la_SOURCES = \
+ Parser.cpp \
+ Parser.hpp \
+ Serialiser.cpp \
+ Serialiser.hpp \
+ serialisation.cpp \
+ serialisation.hpp
+