summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index caa84b2b..521a11c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,10 @@ if test "$build_server" = "yes" -o "$monolothic_ingenuity"; then
fi
if test "$build_jack_midi" = "yes"; then
AC_DEFINE(HAVE_JACK_MIDI, 1, [Has Jack MIDI])
+ AC_JACK_MIDI_NFRAMES_CHECK()
+ if test "$jackmidi_nframes" == "yes"; then
+ AC_DEFINE([JACK_MIDI_NEEDS_NFRAMES], 1, [Defined if we JACK MIDI functions need nframes parameter.])
+ fi
fi
# Check for ALSA