summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 8 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index ad46411b..ff60df7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,10 +7,9 @@ AC_CONFIG_SRCDIR([src/libs/engine/JackAudioDriver.cpp])
AC_CONFIG_SRCDIR([src/libs/engine/tests/node_tree_test.cpp])
AC_CONFIG_SRCDIR([src/libs/serialisation/Loader.cpp])
AC_CONFIG_SRCDIR([src/libs/client/OSCController.cpp])
-AC_CONFIG_SRCDIR([src/progs/server/main.cpp])
-AC_CONFIG_SRCDIR([src/progs/patch_loader/patch_loader.cpp])
+AC_CONFIG_SRCDIR([src/libs/gui/App.cpp])
+AC_CONFIG_SRCDIR([src/progs/ingen/main.cpp])
AC_CONFIG_SRCDIR([src/progs/demolition/demolition.cpp])
-AC_CONFIG_SRCDIR([src/progs/ingenuity/main.cpp])
AC_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
@@ -365,15 +364,13 @@ AC_CONFIG_FILES([src/libs/engine/tests/Makefile])
AC_CONFIG_FILES([src/libs/engine/events/Makefile])
AC_CONFIG_FILES([src/libs/serialisation/Makefile])
AC_CONFIG_FILES([src/libs/client/Makefile])
+AC_CONFIG_FILES([src/libs/gui/Makefile])
AC_CONFIG_FILES([src/progs/Makefile])
-AC_CONFIG_FILES([src/progs/server/Makefile])
+AC_CONFIG_FILES([src/progs/ingen/Makefile])
AC_CONFIG_FILES([src/progs/supercollider/Makefile])
AC_CONFIG_FILES([src/progs/python/Makefile])
AC_CONFIG_FILES([src/progs/python/scripts/Makefile])
-AC_CONFIG_FILES([src/progs/demolition/Makefile])
-AC_CONFIG_FILES([src/progs/patch_loader/Makefile])
-AC_CONFIG_FILES([src/progs/ingenuity/Makefile])
-AC_CONFIG_FILES([src/progs/ingenuity/ingenuity.desktop])
+AC_CONFIG_FILES([src/progs/ingen/ingen.desktop])
AC_CONFIG_FILES([patches/Makefile])
AC_CONFIG_FILES([doc/Doxyfile])
AC_OUTPUT
@@ -382,7 +379,8 @@ AC_MSG_RESULT([])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([Ingen build configuration:])
AC_MSG_RESULT([])
-AC_MSG_RESULT([Building server: $build_engine])
+AC_MSG_RESULT([Building engine: $build_engine])
+AC_MSG_RESULT([ JACK in-process support: $build_in_process_engine])
AC_MSG_RESULT([ Jack MIDI support: $build_jack_midi])
AC_MSG_RESULT([ ALSA MIDI support: $build_alsa_midi])
AC_MSG_RESULT([ LV2 Plugin support: $build_lv2])
@@ -390,11 +388,9 @@ AC_MSG_RESULT([ DSSI Plugin support: $build_dssi])
AC_MSG_RESULT([ LADSPA Plugin support: $build_ladspa])
AC_MSG_RESULT([ LASH support: $build_lash])
AC_MSG_RESULT([])
-AC_MSG_RESULT([Building in-process engine: $build_in_process_engine])
-AC_MSG_RESULT([])
AC_MSG_RESULT([Building console clients: $build_console_clients])
AC_MSG_RESULT([])
-AC_MSG_RESULT([Building Ingenuity (GTK): $build_gtk_client])
+AC_MSG_RESULT([Building GUI: $build_gtk_client])
AC_MSG_RESULT([])
AC_MSG_RESULT([AGAIN, LASH SUPPORT IS NOT AVAILABLE.])
AC_MSG_RESULT([THERE IS NO LASH SUPPORT IN INGEN AT THIS TIME])