summaryrefslogtreecommitdiffstats
path: root/icons/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'icons/meson.build')
-rw-r--r--icons/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/icons/meson.build b/icons/meson.build
new file mode 100644
index 00000000..74a2038f
--- /dev/null
+++ b/icons/meson.build
@@ -0,0 +1,24 @@
+# Copyright 2022 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR GPL-3.0-or-later
+
+png_icon_sizes = [
+ '16x16',
+ '22x22',
+ '24x24',
+ '32x32',
+ '48x48',
+ '64x64',
+ '128x128',
+ '256x256',
+]
+
+icons_dir = get_option('prefix') / get_option('datadir') / 'icons' / 'hicolor'
+
+install_data('scalable/ingen.svg', install_dir: icons_dir / 'scalable' / 'apps')
+
+foreach size : png_icon_sizes
+ install_data(
+ files(size / 'ingen.png'),
+ install_dir: icons_dir / size / 'apps',
+ )
+endforeach