summaryrefslogtreecommitdiffstats
path: root/src/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/client/Makefile.am')
-rw-r--r--src/client/Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/client/Makefile.am b/src/client/Makefile.am
new file mode 100644
index 00000000..4af7c243
--- /dev/null
+++ b/src/client/Makefile.am
@@ -0,0 +1,69 @@
+if BUILD_CLIENT_LIB
+
+
+moduledir = $(libdir)/ingen
+
+module_LTLIBRARIES = libingen_client.la
+
+libingen_client_la_CXXFLAGS = \
+ -DPKGDATADIR=\"$(pkgdatadir)\" \
+ @INGEN_CFLAGS@ \
+ @GLIBMM_CFLAGS@ \
+ @LIBLO_CFLAGS@ \
+ @LSIGCPP_CFLAGS@ \
+ @GLIBMM_CFLAGS@ \
+ @LXML2_CFLAGS@ \
+ @RAUL_CFLAGS@ \
+ @REDLANDMM_CFLAGS@ \
+ @SLV2_CFLAGS@ \
+ @SOUP_CFLAGS@
+
+libingen_client_la_LIBADD = \
+ ../shared/libingen_shared.la \
+ @GLIBMM_LIBS@ \
+ @LIBLO_LIBS@ \
+ @LSIGCPP_LIBS@ \
+ @LXML2_LIBS@ \
+ @RAUL_LIBS@ \
+ @REDLANDMM_LIBS@ \
+ @SLV2_LIBS@ \
+ @SOUP_LIBS@
+
+libingen_client_la_SOURCES = \
+ ClientStore.cpp \
+ ClientStore.hpp \
+ ConnectionModel.hpp \
+ DeprecatedLoader.cpp \
+ DeprecatedLoader.hpp \
+ NodeModel.cpp \
+ NodeModel.hpp \
+ OSCClientReceiver.cpp \
+ OSCClientReceiver.hpp \
+ OSCEngineSender.cpp \
+ OSCEngineSender.hpp \
+ ObjectModel.cpp \
+ ObjectModel.hpp \
+ PatchModel.cpp \
+ PatchModel.hpp \
+ PluginModel.cpp \
+ PluginModel.hpp \
+ PluginUI.cpp \
+ PluginUI.hpp \
+ PortModel.cpp \
+ PortModel.hpp \
+ SigClientInterface.hpp \
+ ThreadedSigClientInterface.cpp \
+ ThreadedSigClientInterface.hpp \
+ client.cpp \
+ client.hpp
+
+if WITH_SOUP
+libingen_client_la_SOURCES += \
+ HTTPClientReceiver.cpp \
+ HTTPClientReceiver.hpp \
+ HTTPEngineSender.cpp \
+ HTTPEngineSender.hpp
+endif
+
+endif # BUILD_CLIENT_LIB
+