summaryrefslogtreecommitdiffstats
path: root/src/clients/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/clients/Makefile.am')
-rw-r--r--src/clients/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/src/clients/Makefile.am b/src/clients/Makefile.am
deleted file mode 100644
index 24e6a3bb..00000000
--- a/src/clients/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-AM_CXXFLAGS = -I$(top_srcdir)/src/common -fno-exceptions -fno-rtti
-
-SUBDIRS = . python supercollider
-
-if BUILD_CONSOLE_CLIENTS
-noinst_LIBRARIES = libomclient.a
-
-libomclient_a_CXXFLAGS = -I$(top_srcdir)/src/common -DPKGDATADIR=\"$(pkgdatadir)\" $(LIBGLADEMM_CFLAGS) $(GNOMECANVASMM_CFLAGS) $(JACK_CFLAGS) $(LXML2_CFLAGS)
-
-libomclient_a_SOURCES = \
- ClientInterface.h \
- OSCEngineInterface.h \
- OSCEngineInterface.cpp \
- OSCModelEngineInterface.h \
- OSCModelEngineInterface.cpp \
- OSCListener.h \
- OSCListener.cpp \
- SigClientInterface.h \
- DirectSigClientInterface.h \
- ThreadedSigClientInterface.h \
- ThreadedSigClientInterface.cpp \
- ModelEngineInterface.h \
- ModelClientInterface.h \
- ModelClientInterface.cpp \
- PresetModel.h \
- ControlModel.h \
- ObjectController.h \
- ObjectModel.h \
- ObjectModel.cpp \
- NodeModel.h \
- NodeModel.cpp \
- PortModel.h \
- PatchModel.h \
- PatchModel.cpp \
- PluginModel.h \
- PatchLibrarian.h \
- PatchLibrarian.cpp \
- ConnectionModel.h \
- ConnectionModel.cpp \
- $(top_srcdir)/src/common/util/Path.h \
- $(top_srcdir)/src/common/interface/ClientInterface.h \
- $(top_srcdir)/src/common/interface/EngineInterface.h
-
-SUBDIRS += patch_loader patches demolition
-
-endif # BUILD_CONSOLE_CLIENTS
-
-if BUILD_GTK_CLIENT
-SUBDIRS += gtk
-endif
-