summaryrefslogtreecommitdiffstats
path: root/src/libs/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/client/Makefile.am')
-rw-r--r--src/libs/client/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/libs/client/Makefile.am b/src/libs/client/Makefile.am
index 565c94cf..4af7c243 100644
--- a/src/libs/client/Makefile.am
+++ b/src/libs/client/Makefile.am
@@ -35,10 +35,6 @@ libingen_client_la_SOURCES = \
ConnectionModel.hpp \
DeprecatedLoader.cpp \
DeprecatedLoader.hpp \
- HTTPClientReceiver.cpp \
- HTTPClientReceiver.hpp \
- HTTPEngineSender.cpp \
- HTTPEngineSender.hpp \
NodeModel.cpp \
NodeModel.hpp \
OSCClientReceiver.cpp \
@@ -61,5 +57,13 @@ libingen_client_la_SOURCES = \
client.cpp \
client.hpp
+if WITH_SOUP
+libingen_client_la_SOURCES += \
+ HTTPClientReceiver.cpp \
+ HTTPClientReceiver.hpp \
+ HTTPEngineSender.cpp \
+ HTTPEngineSender.hpp
+endif
+
endif # BUILD_CLIENT_LIB