summaryrefslogtreecommitdiffstats
path: root/src/libs/serialisation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/serialisation/Makefile.am')
-rw-r--r--src/libs/serialisation/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/libs/serialisation/Makefile.am b/src/libs/serialisation/Makefile.am
new file mode 100644
index 00000000..f1343463
--- /dev/null
+++ b/src/libs/serialisation/Makefile.am
@@ -0,0 +1,16 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+moduledir = $(libdir)/ingen
+
+module_LTLIBRARIES = libingen_serialisation.la
+
+libingen_serialisation_la_CXXFLAGS = @RAUL_CFLAGS@ -I$(top_srcdir)/src/common
+libingen_serialisation_la_LDFLAGS = -no-undefined -module -avoid-version
+libingen_serialisation_la_LIBADD = @RAUL_LIBS@
+
+libingen_serialisation_la_SOURCES = \
+ serialisation.h \
+ serialisation.cpp \
+ Loader.h \
+ Loader.cpp
+