summaryrefslogtreecommitdiffstats
path: root/src/progs/ingen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/progs/ingen/Makefile.am')
-rw-r--r--src/progs/ingen/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/progs/ingen/Makefile.am b/src/progs/ingen/Makefile.am
new file mode 100644
index 00000000..9915cae5
--- /dev/null
+++ b/src/progs/ingen/Makefile.am
@@ -0,0 +1,16 @@
+AM_CXXFLAGS = @RAUL_CFLAGS@ -I$(top_srcdir)/src/common -I$(top_srcdir)/src/libs -DINGEN_MODULE_DIR=\"$(libdir)/ingen\"
+
+MAINTAINERCLEANFILES = Makefile.in
+EXTRA_DIST = ingen_dev
+
+desktopfilesdir = $(datadir)/applications
+dist_desktopfiles_DATA = ingen.desktop
+
+bin_PROGRAMS = ingen
+ingen_LDADD = @RAUL_LIBS@ ../../libs/module/libingen_module.la
+ingen_DEPENDENCIES = ../../libs/module/libingen_module.la
+
+ingen_SOURCES = \
+ main.cpp \
+ cmdline.h \
+ cmdline.c