summaryrefslogtreecommitdiffstats
path: root/doc/html/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/html/meson.build')
-rw-r--r--doc/html/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/doc/html/meson.build b/doc/html/meson.build
new file mode 100644
index 0000000..59da474
--- /dev/null
+++ b/doc/html/meson.build
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+html_dir = docdir / versioned_name / 'html'
+
+# TODO: Add install_tag: 'doc' after requiring meson 0.60.0
+
+custom_target(
+ 'html',
+ build_by_default: true,
+ command: sphinx_build_command + [
+ '-b', 'html',
+ '-t', 'html',
+ sphinx_in_dir,
+ '@OUTDIR@',
+ ],
+ input: [api_lilv_rst, conf_py, sphinx_input],
+ install: true,
+ install_dir: html_dir,
+ output: [
+ 'index.html',
+
+ '_static',
+ 'api',
+ 'genindex.html',
+ 'overview.html',
+ 'plugins.html',
+ 'uis.html',
+ 'world.html',
+ ],
+)
+
+if not meson.is_subproject()
+ summary(
+ 'HTML',
+ get_option('prefix') / html_dir,
+ section: 'Directories',
+ )
+endif