summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
new file mode 100644
index 0000000..6c12b26
--- /dev/null
+++ b/swig/Makefile.am
@@ -0,0 +1,12 @@
+EXTRA_DIST = slv2.i lv2_list.py
+
+if WITH_SWIG
+all:
+ swig -Wall -python slv2.i
+ gcc -fPIC -shared -I/usr/include/python2.4 slv2_wrap.c ../src/.libs/libslv2.so -o _slv2.so
+endif
+
+clean:
+ rm *.c
+ rm *.so
+ rm *.o