summaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
new file mode 100644
index 0000000..4415de1
--- /dev/null
+++ b/test/headers/meson.build
@@ -0,0 +1,27 @@
+# Copyright 2020-2025 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: 0BSD OR ISC
+
+header_c_suppressions = []
+
+if get_option('warning_level') == 'everything'
+ if cc.get_id() == 'clang'
+ if not meson.is_cross_build()
+ header_c_suppressions += ['-Wno-poison-system-directories']
+ endif
+ endif
+endif
+
+if cc.get_id() == 'clang'
+ header_c_suppressions += ['-Wno-nullability-extension']
+endif
+
+test(
+ 'headers',
+ executable(
+ 'test_headers',
+ files('test_headers.c'),
+ c_args: header_c_suppressions,
+ dependencies: lilv_dep,
+ ),
+ suite: 'unit',
+)