aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 552ceb7..47be94f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,13 @@ if test "$with_jack" = "yes"; then
fi
fi
AM_CONDITIONAL(WITH_JACK, [test "$with_jack" = "yes"])
+if test "$with_jack" = "yes"; then
+ AC_DEFINE(HAVE_JACK_MIDI, 1, [Has Jack MIDI])
+ AC_JACK_MIDI_NFRAMES_CHECK()
+ if test "$jackmidi_nframes" == "yes"; then
+ AC_DEFINE([JACK_MIDI_NEEDS_NFRAMES], 1, [Defined if we JACK MIDI functions need nframes parameter.])
+ fi
+fi
# Check for debugging flag
debug="no"