summaryrefslogtreecommitdiffstats
path: root/icons/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-01-06 02:23:58 +0000
committerDavid Robillard <d@drobilla.net>2008-01-06 02:23:58 +0000
commitb43eaf9a9521a55c6cbbedb62147c2daaaf6e32d (patch)
treed4e52465ff47ee7ed962aaa180f5509ce36f4bec /icons/Makefile.am
parent00176fa0e8e834608efa5b2a44b3954132fb13ea (diff)
downloadpatchage-b43eaf9a9521a55c6cbbedb62147c2daaaf6e32d.tar.gz
patchage-b43eaf9a9521a55c6cbbedb62147c2daaaf6e32d.tar.bz2
patchage-b43eaf9a9521a55c6cbbedb62147c2daaaf6e32d.zip
Install icon to standard (themeable) location.
git-svn-id: http://svn.drobilla.net/lad/patchage@1013 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'icons/Makefile.am')
-rw-r--r--icons/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/icons/Makefile.am b/icons/Makefile.am
new file mode 100644
index 0000000..79835fc
--- /dev/null
+++ b/icons/Makefile.am
@@ -0,0 +1,14 @@
+SUBDIRS = 16x16 22x22 24x24 32x32 48x48
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi