aboutsummaryrefslogtreecommitdiffstats
path: root/bindings/cpp/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-10-07 15:00:52 -0400
committerDavid Robillard <d@drobilla.net>2022-10-07 15:00:52 -0400
commit71fa73303e8df651edaf606c07ded6fec2b066af (patch)
tree72cd81a5d2e5be1d856300c40de7c368f26bc4bc /bindings/cpp/meson.build
parentb0af14c346817c6660ab135c7b542205e8e59b7d (diff)
downloadpugl-71fa73303e8df651edaf606c07ded6fec2b066af.tar.gz
pugl-71fa73303e8df651edaf606c07ded6fec2b066af.tar.bz2
pugl-71fa73303e8df651edaf606c07ded6fec2b066af.zip
Override pkg-config dependencies within meson
Diffstat (limited to 'bindings/cpp/meson.build')
-rw-r--r--bindings/cpp/meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/bindings/cpp/meson.build b/bindings/cpp/meson.build
index 313f1df..0383eed 100644
--- a/bindings/cpp/meson.build
+++ b/bindings/cpp/meson.build
@@ -9,10 +9,14 @@ puglpp_dep = declare_dependency(
link_with: libpugl,
)
+puglpp_versioned_name = 'puglpp-@0@'.format(major_version)
+
pkg.generate(
description: 'Pugl GUI library C++ bindings',
- filebase: 'puglpp-@0@'.format(major_version),
+ filebase: puglpp_versioned_name,
name: 'Pugl++',
- subdirs: ['puglpp-@0@'.format(major_version)],
+ subdirs: [puglpp_versioned_name],
version: meson.project_version(),
)
+
+meson.override_dependency(puglpp_versioned_name, puglpp_dep)