aboutsummaryrefslogtreecommitdiffstats
path: root/examples/pugl_clipboard_demo.app/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-05-06 17:14:58 -0400
committerDavid Robillard <d@drobilla.net>2022-05-22 20:16:26 -0400
commit7c9d6d5d16fc0c72a27f0118ac753980e518ebcd (patch)
treedc977252a7d93a4ca5fe840b978568178708e873 /examples/pugl_clipboard_demo.app/meson.build
parentfdd6de0d12ea17f713ec3e73e7968198339b7b6d (diff)
downloadpugl-7c9d6d5d16fc0c72a27f0118ac753980e518ebcd.tar.gz
pugl-7c9d6d5d16fc0c72a27f0118ac753980e518ebcd.tar.bz2
pugl-7c9d6d5d16fc0c72a27f0118ac753980e518ebcd.zip
Factor out pugl_clipboard_demo example program
This is a simpler example than pugl_embed_demo that demonstrates clipboard functionality without the complexity of embedded views.
Diffstat (limited to 'examples/pugl_clipboard_demo.app/meson.build')
-rw-r--r--examples/pugl_clipboard_demo.app/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/pugl_clipboard_demo.app/meson.build b/examples/pugl_clipboard_demo.app/meson.build
new file mode 100644
index 0000000..fff35b9
--- /dev/null
+++ b/examples/pugl_clipboard_demo.app/meson.build
@@ -0,0 +1,11 @@
+# Copyright 2021 David Robillard <d@drobilla.net>
+# SPDX-License-Identifier: CC0-1.0 OR ISC
+
+config = configuration_data()
+config.set('NAME', 'pugl_clipboard_demo')
+
+info_plist = configure_file(configuration: config,
+ input: files('../../resources/Info.plist.in'),
+ output: 'Info.plist')
+
+subdir('MacOS')