aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2022-06-05 20:24:51 -0400
committerDavid Robillard <d@drobilla.net>2022-06-08 19:48:13 -0400
commit27ce10b5039e931eaad33e9499a630552d4e1f06 (patch)
tree9ad33d28562935d72f768e68e9d24531b6059d8a /meson.build
parentbb0fe3975df149eb45a21e39940f71e2273c8fd5 (diff)
downloadpugl-27ce10b5039e931eaad33e9499a630552d4e1f06.tar.gz
pugl-27ce10b5039e931eaad33e9499a630552d4e1f06.tar.bz2
pugl-27ce10b5039e931eaad33e9499a630552d4e1f06.zip
Separate private and public function implementations
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ed78497..8176447 100644
--- a/meson.build
+++ b/meson.build
@@ -151,9 +151,14 @@ if library_type == 'static_library'
add_project_arguments(['-DPUGL_STATIC'], language: ['c', 'cpp', 'objc'])
endif
+common_sources = files(
+ 'src/common.c',
+ 'src/internal.c',
+)
+
libpugl = build_target(
core_name,
- files('src/implementation.c') + platform_sources,
+ common_sources + platform_sources,
version: meson.project_version(),
include_directories: includes,
c_args: library_args + core_args,