aboutsummaryrefslogtreecommitdiffstats
path: root/doc/cpp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/cpp/meson.build')
-rw-r--r--doc/cpp/meson.build12
1 files changed, 8 insertions, 4 deletions
diff --git a/doc/cpp/meson.build b/doc/cpp/meson.build
index ad25319..358a042 100644
--- a/doc/cpp/meson.build
+++ b/doc/cpp/meson.build
@@ -25,8 +25,10 @@ subdir('xml')
subdir('api')
docs = custom_target(
- 'C++ API Documentation (singlehtml)',
- command: [sphinx_build, '-M', 'singlehtml', 'doc/cpp/', 'doc/cpp/', '-E', '-q', '-t', 'singlehtml'],
+ 'singlehtml C++ documentation for pugl',
+ command: [sphinx_build, '-M', 'singlehtml',
+ meson.current_build_dir(), meson.current_build_dir(),
+ '-E', '-q', '-t', 'singlehtml'],
input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
output: 'singlehtml',
build_by_default: true,
@@ -34,8 +36,10 @@ docs = custom_target(
install_dir: docdir / 'puglpp-0')
docs = custom_target(
- 'C++ API Documentation (html)',
- command: [sphinx_build, '-M', 'html', 'doc/cpp/', 'doc/cpp/', '-E', '-q', '-t', 'html'],
+ 'html C++ documentation for pugl',
+ command: [sphinx_build, '-M', 'html',
+ meson.current_build_dir(), meson.current_build_dir(),
+ '-E', '-q', '-t', 'html'],
input: [cpp_rst_files, cpp_pugl_rst, cpp_index_xml],
output: 'html',
build_by_default: true,