aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7a8690d..e84bde1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-# Copyright 2021 David Robillard <d@drobilla.net>
+# Copyright 2021-2022 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: CC0-1.0 OR ISC
project('pugl', ['c'],
@@ -172,9 +172,12 @@ elif host_machine.system() == 'windows'
add_project_arguments(win_args, language: ['c', 'cpp'])
+ user32_dep = cc.find_library('user32')
+ shlwapi_dep = cc.find_library('shlwapi')
+
platform = 'win'
platform_sources = files('src/win.c')
- core_deps = []
+ core_deps = [user32_dep, shlwapi_dep]
extension = '.c'
else # X11