aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c135329..b3c88e6 100644
--- a/meson.build
+++ b/meson.build
@@ -77,16 +77,14 @@ if get_option('strict')
endif
elif cc.get_id() == 'msvc'
c_warnings += [
- '/wd4028', # formal parameter different from declaration
'/wd4061', # enumerator in switch is not explicitly handled
'/wd4191', # unsafe conversion from type to type
'/wd4514', # unreferenced inline function has been removed
'/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
- '/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
- '/wd4996', # function or variable may be unsafe
+ '/wd4996', # POSIX name for this item is deprecated
'/wd5045', # will insert Spectre mitigation for memory load
]
endif