aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 50cc19f..f5e8f12 100644
--- a/meson.build
+++ b/meson.build
@@ -140,7 +140,15 @@ if get_option('strict')
# Objective C warnings
if is_variable('objcc')
- add_project_arguments(objcc.get_supported_arguments(all_objc_warnings),
+ objc_warnings = all_objc_warnings
+
+ objc_warnings += [
+ '-Wno-deprecated-declarations',
+ '-Wno-direct-ivar-access',
+ '-Wno-pedantic',
+ ]
+
+ add_project_arguments(objcc.get_supported_arguments(objc_warnings),
language: ['objc'])
endif
endif
@@ -204,9 +212,6 @@ if host_machine.system() == 'darwin'
core_deps = [cocoa_dep, corevideo_dep]
extension = '.m'
- add_project_arguments(['-Wno-deprecated-declarations'], language: ['objc'])
- add_project_arguments(['-Wno-direct-ivar-access'], language: ['objc'])
-
add_project_arguments(['-DGL_SILENCE_DEPRECATION'],
language: ['c', 'objc'])